1004 成绩排名

读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含 1 个测试用例,格式为

 1 行:正整数 n
 2 行:第 1 个学生的姓名 学号 成绩
 3 行:第 2 个学生的姓名 学号 成绩
  ... ... ...
 n+1 行:第 n 个学生的姓名 学号 成绩

其中姓名学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112

代码

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <functional>
using namespace std;

class student {
private:
    string _name;
    string _num;
    int _score;
public:
    student(string &name,string &num,int &score):_name(name),_num(num),_score(score){}
    auto operator<(student &s2)->bool {return this->_score>s2._score;}
    void print(){
        cout << _name << " " << _num << endl;
    }
};

int  main(){
    int n;
    string num,name;
    int score;
    scanf("%d",&n);
    vector<student> v;
    for(auto i=0;i<n;i++){
        cin >> name >> num >> score;
        v.emplace_back(student(name,num,score));
    }
    sort(v.begin(),v.end());
    (*v.begin()).print();
    (*(v.end()-1)).print();
}

最后更新: 2020-05-27