1001 A+B Format¶
Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:¶
Each input file contains one test case. Each case contains a pair of integers a and b where −10^6≤a,b≤10^6. The numbers are separated by a space.
Output Specification:¶
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:¶
-1000000 9
Sample Output:¶
-999,991
#include<bits/stdc++.h>
using namespace std;
int main()
{
long long a, b, flag = 0, res, cnt = 0, t;
stack<char> s;
cin >> a >> b;
res = a + b;
if(res >= 0)
flag = 1;
else
res = -res;
while(1)
{
t = res % 10;
s.push(t + 48);
cnt++;
res = res /10;
if(res == 0)
break;
if(cnt % 3 == 0)
s.push(',');
}
if(!flag)
cout << "-";
while(!s.empty())
{
cout << s.top();
s.pop();
}
return 0;
}
最后更新: 2020-05-27