1004 Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1
#include<bits/stdc++.h>
#define N 111
using namespace std;
int n,m,d[N],ans[N];
vector<int> G[N];
void dfs(int u,int fa=0)
{
    d[u]=d[fa]+1;
    ans[d[u]]+=G[u].empty();
    for(int v:G[u])
        if(v!=fa)
            dfs(v,u);
}
int main()
{
    cin>>n>>m;
    for(int i=1,k,u,v;i<=m;i++)
    {
        cin>>u>>k;
        for(int j=1;j<=k;j++)
        {
            cin>>v;
            G[u].push_back(v);
        }
    }
    dfs(1);
    for(int i=1;i<=*max_element(d,d+1+n);i++)
        cout<<(i>1?" ":"")<<ans[i];
}

最后更新: 2020-05-27