1009 Product of Polynomials

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K\ N_1\ a_{N_1}\ N_2\ a_{N_2}\ ...\ N_k\ a_{N_k}

where K is the number of nonzero terms in the polynomial, N_i and a_{N_i}(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N_K<⋯<N_2<N_1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6
#include<bits/stdc++.h>
#define N 2010
using namespace std;
double a[N],b[N],c[N];
int n,m,cnt;
int main()
{
    cin>>n;
    for(int i=0,t;i<n;i++)
    {
        cin>>t;
        cin>>a[t];
    }
    cin>>m;
    for(int i=0,t;i<m;i++)
    {
        cin>>t;
        cin>>b[t];
    }
    for(int i=0;i<=1000;i++)
        for(int j=0;j<=1000;j++)
            c[i+j]+=a[i]*b[j];
    for(int i=2000;i>=0;i--)
        cnt+=!!c[i];
    cout<<cnt;
    for(int i=2000;i>=0;i--)
        if(c[i])
            printf(" %d %.1f",i,c[i]);
}

最后更新: 2020-05-27